[XML-SIG] PyXML + 4Suite compatibility

Michael Olson Mike.Olson at fourthought.com
Thu Jun 5 07:48:10 EDT 2003

On Thursday, June 5, 2003, at 01:35 AM, Torsten Rueger wrote:

> Newbie question:
> I have 4Suite installed and am using the xml + xpath packages.
> If I install PyXML, will 4suite still work ?

Yes.  4Suite is designed to work with PyXML.  Infact you need 4Suite  
installed to perform validation.

> Will PyXML, specifically the xpath stuff work ?

The xpath implementation that ships with PyXML is out of date.  We will  
be resynching it shortly, but for now you will want to use Ft.Xml.XPath

> PS: I don't want to use both at the same time. Just trying to evaluate  
> which one to use.
> Can anyone share some experiences about the difference ?

They are both from the same code base.  xml.xpath was copied from  
4Suite over a year a go and I don't think anyone has had the time to  
update it since then.

Hope that helps

> Thanks
>   Torsten
> _______________________________________________
> XML-SIG maillist  -  XML-SIG at python.org
> http://mail.python.org/mailman/listinfo/xml-sig
Mike Olson                                                Principal  
mike.olson at fourthought.com                +1 303 583 9900
Fourthought, Inc.                                       
PO Box 270590,                                       http://4Suite.org
Louisville, CO 80027-5009, USA
XML strategy, XML tools, knowledge management

More information about the XML-SIG mailing list