[XML-SIG] specifying xsl:version number with 4xslt

Mike Brown mike at skew.org
Mon Jun 30 10:09:12 EDT 2003

Uche Ogbuji wrote:
> > I tried installing 1.0a1, but am having some trouble:
> >   File "/home/jedp/lib/python/Ft/Xml/XPath/ParsedAbbreviatedAbsoluteLocationPath.py", line 16, in ?
> >     from Ft.Xml.XPath import Util
> > ImportError: cannot import name Util
> I'm not sure what's going on here.  First I've ehard of such a problem.  Then 
> again, Python 2.1 blows up under some circular import situatrions that Python 
> 2.2 handles OK.  Then again I and others have used 4XSLT 1.0a1+ just fine 
> under python 2.1.

Yeah. Something is hosed. Since this is an upgrade situation, I'd recommend
first blowing away everything under /home/jedp/lib/python/Ft and reinstalling.

Also I wonder if it has anything to do with the nonstandard lib dir. That's
something we haven't tested ourselves, I don't think.

1.0a1 does need a patch if you're using Python 2.1, but only if you're using
the HTTP server. Info is in the Known Bugs list on 4suite.org.

Discussion should continue on the 4suite list.

More information about the XML-SIG mailing list