[XML-SIG] I don't understand this error -- please help

Michael McKerns mmckerns at its.caltech.edu
Mon Jun 30 14:08:20 EDT 2003

On Sat, 28 Jun 2003, M.-A. Lemburg wrote:

> The question is: why would mod_python or your program want to run in
> restricted execution mode (= __builtins__ doesn't point to the
> standard Python builtins dictionary) ?

I don't know.  If you look at the test code I provided, essentially all I
am doing is importing the Sax2 reader & mod_python's apache.py

Python2.2.2 and this:
from xml.dom.ext.reader.Sax2 import FromXml
from mod_python import apache
is enough to cause the error.

Moving to Python2.3 or back to Python2.1 fixes the problem in the short
term, but I'll see what happens when I make a sitecustomize.py...

More information about the XML-SIG mailing list