[XML-SIG] 4suite and python2.3.2?

Jed Parsons jedp at ilm.com
Fri Jan 16 20:09:31 EST 2004

Hello -

I had it working fine with python 2.1, but I'm having trouble getting 4suite
working with python 2.3.2.

I've installed PyXML-0.8.3, and have tried 4Suite-1.0a1, 2, and 3.

Some things work, some things do not.  In particular, I can't get the xslt
tools to work:

> python
Python 2.3.2 (#1, Oct 13 2003, 14:53:27) 
[GCC 2.96 20000731 (Red Hat Linux 7.1 2.96-98)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import Ft.Xml
>>> from Ft.Xml import InputSource
>>> st = InputSource.DefaultFactory.fromString("<?xml version='1.0'?><test />", 'no-uri')
>>> from Ft.Xml.Xslt.Processor import Processor
# hangs forever, but can be interrupted with ctrl-c ...

Same thing happens from the command line.  At the command line, when I hit
ctrl-c, the usage messages get flushed and printed as the program terminates.
(If that's any help.)

Many thanks for any advice, or any documentation anyone could point me to.


Jed Parsons                        / Industrial Light + Magic : 415.448.2974

More information about the XML-SIG mailing list