[XML-SIG] Installation of XML package v0.8.3

Mike Brown mike at skew.org
Sat Dec 2 01:30:22 CET 2006

[cc'ing the list again]

Yes, it's possible to install PyXML in a location separate from Python

1. set PYTHONPATH to ~/mypythonlibs/lib/python
2. python setup.py install --home=~/mypythonlibs

Note the "/lib/python" is on PYTHONPATH but *not* on --home.

PyXML will install 2 xmlproc scripts into ~/mypythonlibs/bin
(normally they'd go into /usr/bin or /usr/local/bin)
and everything else into ~/mypythonlibs/lib/python/_xmlplus.
(normally they'd go into Python's site-packages folder)

As long as PYTHONPATH is set you should be able to
access the new and extended libraries. A quick test that
should produce no error:

python -c "from xml import marshal"

Thanks to Jeremy Kloth for assistance getting this answer together for you.

By the way, what PyXML features are you planning to use?

SAROLI Andre Intérimaire wrote:
> Thanks for your answer,
> First I use XML package  0.8.4 and not  0.8.3.
> I'm sorry but I don't anderstand the answer.
> Python is installed in /usr/bin/ but I'm not root on this station and before calling the administrator, I want to try the package so I want to install it in the folder /home/toto/
> Is it possible to do that and if it is, how can I make it?
> Thanks for all.
> -----Message d'origine-----
> De : Mike Brown [mailto:mike at skew.org] 
> Envoyé : jeudi 30 novembre 2006 18:52
> À : SAROLI Andre Intérimaire
> Cc : xml-sig at python.org
> Objet : Re: [XML-SIG] Installation of XML package v0.8.3
> SAROLI Andre Int￿imaire wrote:
> > I want to install the XML package v0.8.3 on my station. I want to install it in an other directory of the previous python folder.
> > 
> > In the setup.py -help-commands I have not found the command which allow to change the installation folder, like for some other scripts I make "-prefix=/home/toto".
> It should install relative to the python interpret you use to run setup.py.
> For example, instead of 'setup.py install',
> do '/path/to/your/python setup.py install'
> Is that sufficient?
> Also, why 0.8.3 and not 0.8.4?

More information about the XML-SIG mailing list