Mike Brown mike at skew.org
Wed Apr 11 17:43:55 CEST 2007

John Dunn wrote:
> I have been asked to install a python application on AIX 5.3 that runs OK on Windows 
> I have installed Python 4.2.2 from python.org and pyXML form 
> sourceforge. 
> However when I run the application I get the following error : 
> class xml.sax._exceptions.SAXReaderNotAvailable 

There should've been a more helpful message associated with that.

In any case, it generally indicates a problem with PyExpat not being found,
which seems strange because even if Python was built without it, PyXML
would've installed it (wrapping Expat 1.95.7; PyXML isn't really maintained

Python's should be in your python lib-dynload dir, e.g. on my FreeBSD system
it's at /usr/local/lib/python2.4/lib-dynload/pyexpat.so.

PyXML's should be at site-packages/_xmlplus/parsers/pyexpat.so.

> Do I need to set some Python environment variables? 

Shouldn't, no.

> Can I test the availibility of this from the python command line. e.g 
> import something? 

import xml.sax

You should get something like
<xml.sax.expatreader.ExpatParser instance at 0x81c52ec>

It's possible there's some kind of conflict between PyXML and Python but
I'm guessing something else is wrong... unfortunately I'm not qualified
to diagnose it further...

More information about the XML-SIG mailing list