[XML-SIG] installing PyXML for Python 2.5

sap28 at kent.ac.uk sap28 at kent.ac.uk
Wed Jun 11 17:50:48 CEST 2008


I'm trying to install PyXML for Python 2.5 on windows XP to be able to use
the validating parser but I have been unsuccessful so far. I tried to
compile the PyXML from the any platform package but I got the following
"running build_ext
error: Python was built with Visual Studio 2003;
extensions must be built with a compiler than can generate compatible
Visual Studio 2003 was not found on this system. If you have Cygwin
you can try compiling with MingW32, by passing "-c mingw32" to setup.py."
(The Python package was added by the installation of the Haptic API H3D
I then installed Cygwin and tried compiling using the indication provided
but either the -c command wasn't recognized or the mingw32 wasn't defined.
I've never really used Cygwin either so I don't quite know if I've
inputted the wrong command or if it just doesn't work.

I also naively tried to just copy the files to check if it could work
without compilation, but i get the following error:
    from xml.parsers import expat
  File "C:\Python25\lib\site-packages\_xmlplus\parsers\expat.py", line 4,
in <module>
    from pyexpat import *
ImportError: DLL load failed: The specified module could not be found.

I really need it to have it working for my phd work, so I would be
grateful if you could help me.

Thanks for your help,
Best regards,

More information about the XML-SIG mailing list