[XML-SIG] PyXML-0.8.4 error

Dieter Maurer dieter at handshake.de
Sun Feb 21 07:30:45 CET 2010

Vinicio Nocciolini wrote at 2010-2-17 11:47 +0100:
>I am using Ubuntu 9.10
>This is the error putput
>regards Vinicio
>PyXML-0.8.4$ python2.5 setup.py build
>running build
>running build_py
>running build_ext
>building '_xmlplus.parsers.pyexpat' extension
>gcc -pthread -fno-strict-aliasing -DNDEBUG -g -fwrapv -O2 -Wall 
>-Wstrict-prototypes -fPIC -DXML_NS=1 -DXML_DTD=1 -DBYTEORDER=1234 
>-DXML_CONTEXT_BYTES=1024 -DHAVE_MEMMOVE=1 -Iextensions/expat/lib 
>-I/usr/include/python2.5 -c extensions/pyexpat.c -o 
>extensions/pyexpat.c:5:20: error: Python.h: No such file or directory

You need to install the development package for Python
(something like "python-dev") on your system.


More information about the XML-SIG mailing list