[XML-SIG] HTML parse error

Stefan Behnel stefan_ml at behnel.de
Tue Feb 23 11:51:29 CET 2010

sharifah ummu kulthum, 23.02.2010 11:28:
> On Tue, Feb 23, 2010 at 5:46 PM, Stefan Behnel wrote:
>> sharifah ummu kulthum, 23.02.2010 04:45:
>>> I am so sorry but I really don't know how to change the code as I have
>> just
>>> learn python. How am I going to switch the version or to change the code?
>>> Because I don't really understand the code.
>>> Here is the code:
>>> [...]
>> That's some funny code - it uses BeautifulSoup to parse HTML, and then uses
>> lxml to build an XML tree from it - instead of using just lxml in the first
>> place...
>> Please send an e-mail to the original author of the tool to tell him/her
>> about the problem. Use the project mailing list for this (if there is one).
>> If that doesn't help, I'd suggest installing BeautifulSoup 3.0.8 to see if
>> that helps.
>> I have sent an email to the author and I doubt that it will be a quick
> respond. And this project does not have a mailing list. This is just an
> individual class project that I have to complete which the deadline is so
> close now. How can I install BeautifulSoup 3.0.8?
> # sudo easy_install BeautifulSoup 3.0.8
> like this?

You should consider reading the documentation of easy_install. That would
have told you that you can use

	# sudo easy_install BeautifulSoup==3.0.8

Note that this (and most of the previous thread) is rather off-topic to
this list. The comp.lang.python newsgroup would have been a better choice.


More information about the XML-SIG mailing list