On Wed, 2004-10-27 at 01:26, M.-A. Lemburg wrote:
I think you should rename the "debianize" command to something like "bdist_deb_prepare" or the like. Maybe even make it a bdist_deb subcommand.
What if I rename 'debianize' to 'dh_make'? That should look attractive only to Debian hackers --- and should instantly convey the commands purpose to them as well.
The reason is that this command is likely only going to be used together with bdist_deb unless I misunderstood its purpose.
The 'debianize' command is intended to be used _instead_ of bdist_deb. I see two separate classes of debian packers: 1. Those who just want a binary package, so that they can install it on their Debian machines, taking advantage of Debian's package control. This is the target audience for bdist_deb. 2. Those (either the package author/maintainer himself or a downstream Debian packager) who want to package the python package for inclusion in a/the Debian package repository. It will be tricky for a bdist_deb-like distutils command to make these people happy. Older entries in the debian/changelog need to be maintained (this could be arranged somehow, I guess). But also, it is likely that any automatically-generated set of debian/ files is going to need to be hand-tweaked a bit. The 'debianize' command is intended for this case. It is intended that it be run only once. Thereafter the debian subdirectory is maintained, either as part of the source distribution, or as part of the Debian source package. It is intended that after running 'debianize' (and probably hand-editing the results) the Debian packages are build the Debian way (e.g. using debuild.) Clear? Jeff