aAt Thu, 05 Jul 2012 09:24:33 +0900, Stephen J. Turnbull wrote:
[...] Newsgroup names are an issue here. It seems to me that (if not gateway'd to Usenet) they should be something like (pseudo-code)
"mailman." + join(reverse(split(list-id,".")),".")
Eg, this list would be "mailman.org.python.mailman-developers". I know that's considered ugly-out-the-wazoo, but these need to be UUIDs (consider mirrors), and firstname.lastname@example.org should not be in the same subtree as email@example.com (ie,
mailman.net.python.mailman vs mailman.org.python.mailman
mailman.python.net.mailman vs mailman.python.org.mailman
The top-level maybe shouldn't be "mailman", but rather something like "list-archive".
Currently I am thinking about the naming scheme. I think that we should not split and reverse the list. So currently I implemented something like that (pseudo-code):
join(reverse(split(mail_host, '.')), '.') + ',' + list_name
If the list_name would be also reversed, it could lead to some surprising subtree clashing. For example web2.0 would be in the same subtree like something1.0 (people sometimes use strange list names...). Even with the current implementation the group names are ugly. Maybe we should eliminate the dots from the list names by default and only allow separate groups with the alias mechanism?