Barry Warsaw wrote:
On Aug 4, 2021, at 07:31, Victor Stinner email@example.com wrote:
On Tue, Aug 3, 2021 at 7:54 PM Ethan Furman firstname.lastname@example.org wrote: I would rather keep `bchr` and lose the `.fromint()` methods. I would prefer to only have a bytes.byte(65) method, no bchr() built-in function. I would prefer to keep builtins namespace as small as possible. The Steering Council is also pretty adamantly against adding a new bchr() built-in.
FYI the PEP still mentions `bchr`.
bytes.byte() name is similar to bytes.getbyte(). I cannot find "int" in the name of other bytes methods. .byte() seems fine to me too. I’m not a fan of smushedwords but .fromint() seemed better than .fromord().