I think we have an unwritten rule that test class and method names should tell something about what they test. (We do have things like TestWeirdBugs and test_12345, but I don’t think it’s a useful pattern to follow :)
I completely disagree. test_12345 is a very good name for a test case, in particular if it tests the value of a tau constant in the math module. There can't be any more precise documentation of the test purpose.