Stefan Behnel stefan_ml at behnel.de
Wed Feb 23 20:23:04 CET 2011

Lisandro Dalcin, 23.02.2011 16:43:
> Should we try to support Py_LIMITED_API for Py>=3.2?

I asked the same question a while ago. I think we should, but it won't be 
easy. That API is pretty restricted compared to what Cython currently uses, 
including the internals of builtin types that we use in several places. 
Even the buffer API is not currently part of the limited API, although this 
is being worked on.

I have some doubts this can be done at C compile time, we may have to add a 
compiler switch that lets Cython generate different code, and that disables 
certain optimisations.

I agree with Robert that this will likely require more work than we'd 
currently want to spare, especially given the early state of that API.


More information about the cython-devel mailing list