[Cython] Bug in cython-mode.el under GNU Emacs 23.2.1

Rafe Kettler rafe.kettler at gmail.com
Tue Mar 22 02:57:49 CET 2011

I've just tried out cython-mode.el and I was a bit disappointed when it
didn't work right off the bat.

I added the following to my .emacs:

(setq load-path (cons "~/lib/emacs-plugins" load-path))
(require 'cython-mode)

this initially gave me the following error when I restarted emacs:

    Warning (initialization): An error occurred while loading

    File error: Cannot open load file, python-mode

    To ensure normal operation, you should investigate and remove the
    cause of the error in your initialization file.  Start Emacs with
    the `--debug-init' option to view a complete error backtrace.

So, seeing that python-mode wasn't around, I changed line 3 of
cython-mode.el from (require 'python-mode) to (require 'python) and
everything works now.

I got this mode from Github this morning and it is the latest version (you
can see it at

I'm not an emacs lisp expert, so I'm not sure if there's something I'm
missing here or if I somehow loaded the package correctly. Anyway, I thought
you guys should know that I had a problem with the file but managed to get a
fix. If my fix needs to be applied, I'll patch it on Github.

This is GNU Emacs 23.2.1 x64 on Fedora 14, btw.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/cython-devel/attachments/20110321/f828406c/attachment.html>

More information about the cython-devel mailing list