[Distutils] Backwards compatability: opinions?

Greg Ward gward@cnri.reston.va.us
Wed, 10 Mar 1999 11:28:01 -0500

Hi folks --

I wonder if anyone has strong opinions as to which version(s) of Python
the Distutils should support/require.  I've found a number of silly
little bugs in the 1.5.1 library (I'm coding on my home PC, which isn't
running the latest beta... yet) that have been fixed in 1.5.2.  The
temptation is to assume that everyone is running 1.5.2, and if they're
not... too bad.

The alternative is to allow (at least) 1.5.1, and provide
reimplementations of the buggy functions so that Distutils can work on
pre-1.5.2 Pythons.

I'm not super keen about either option; anyone have strong opinions one
way or the other, or a "middle road" solution?

Greg Ward - software developer                    gward@cnri.reston.va.us
Corporation for National Research Initiatives    
1895 Preston White Drive                      voice: +1-703-620-8990 x287
Reston, Virginia, USA  20191-5434               fax: +1-703-620-0913