[Distutils] Backwards compatability: opinions?

Fred L. Drake Fred L. Drake, Jr." <fdrake@acm.org
Wed, 10 Mar 1999 11:35:27 -0500 (EST)

  My inclination is that 1.5.1 should be supported.  Heck, it's still
the current stable release!
  Even though 1.5.2 will probably be stable before distutils, 1.5.1
just isn't old enough to ignore.  I think any compatibility hacks that 
are needed can go in a module "distutils.compat" (or some such) that
gets imported by the "main" distutils module.  The compat module can
deal with any version checking and update installation it needs to;
this makes the updates as transparent as possible to the rest of the
code, and allows really old things to be taken out later.


Fred L. Drake, Jr.	     <fdrake@acm.org>
Corporation for National Research Initiatives