[Distutils] Backwards compatability: opinions?

Konrad Hinsen hinsen@cnrs-orleans.fr
Wed, 10 Mar 1999 18:44:17 +0100

> The alternative is to allow (at least) 1.5.1, and provide
> reimplementations of the buggy functions so that Distutils can work on
> pre-1.5.2 Pythons.

Maybe I am overly conservative, but I have hesitated for quite a while
before making my code require 1.5!

Keep in mind that our target group includes users who don't care about
Python. They may simply want to use an application written in Python.
Most people I know (computational scientists) use Unix systems that
were set up two to four years ago and then never updated. I am sure
there are still many systems with Python 1.4 out there.

So my vote is for supporting at least 1.5, and if possible even 1.4.

Konrad Hinsen                            | E-Mail: hinsen@cnrs-orleans.fr
Centre de Biophysique Moleculaire (CNRS) | Tel.: +33-
Rue Charles Sadron                       | Fax:  +33-
45071 Orleans Cedex 2                    | Deutsch/Esperanto/English/
France                                   | Nederlands/Francais