[Distutils] Trouble installing Myghty with --prefix

Phillip J. Eby pje at telecommunity.com
Thu Dec 1 01:03:53 CET 2005

At 05:49 PM 11/30/2005 -0600, skip at pobox.com wrote:
>Then, after removing all the previously installed .egg directories and the
>build directory in my Myghty source tree, I tried
>     python setup.py install --prefix=/usr/local/mojam
>again.  Same result.

Argh.  Sorry, I just realized I was ignoring the part where you are using 
"setup.py install" rather than easy_install.  "setup.py install" doesn't 
honor easy_install's options, because it's assumed that only people who 
don't have/use easy_install will run "setup.py install".  So, it's sort of 
a chicken and egg thing here, as I had you edit options that somebody using 
"setup.py install" wouldn't ordinarily be working with.  This is arguably a 
bug in setuptools, so I'll work on fixing it.

In the meantime, you should be able to just do:

     python setup.py easy_install .

in order to do the installation, whether you use distutils.cfg or 

Again, sorry about that, it's a problem with the setuptools "install" 
command, which is just a wrapper around easy_install, but apparently isn't 
loading its config file settings.  I'll fix that as soon as I can.

I should probably also be recommending that authors using setuptools 
recommend that their users refer to the EasyInstall documentation if they 
are installing to custom locations.

More information about the Distutils-SIG mailing list