[Distutils] distutils setup ignoring scripts

jao at geophile.com jao at geophile.com
Tue Mar 15 16:06:39 CET 2005

I'm using Python 2.2 on RH9. I have a set of Python modules organized
into a root package and one other package named foobar. setup.py looks
like this:

     from distutils.core import setup

         name = 'foobar',
         version = '0.3',
         description = 'Foo Bar',
         author = 'Jack Orenstein',
         author_email = 'jao at geophile.com',
         packages = ['', 'xyz'],
         scripts = ['bin/foobar']

The resulting package has everything in the specified directories, but
does not include the script. I've tried making the path bin/foobar
absolute, but that doesn't help. I've googled for known bugs of this
sort but have come up emtpy. (The first line of bin/foobar is

I've also tried using DISTUTIL_DEBUG, which has been uninformative,
(e.g. no mention of bin/foobar at all).

Can anyone see what I'm doing wrong?

Jack Orenstein

This message was sent using IMP, the Internet Messaging Program.

More information about the Distutils-SIG mailing list