[Distutils] Recent upgrade uses security restrictions?

Ben Bangert ben at groovie.org
Wed Nov 16 22:55:00 CET 2005

I ran the setuptools upgrade of Kid to 0.7.1 this morning with no  
problems. When I ran it just now using the latest setuptools, I get  
this error which I've never seen before:

Best match: kid 0.7.1
Downloading http://lesscode.org/dist/kid/0.7.1/kid-0.7.1.tar.gz
Processing kid-0.7.1.tar.gz
Running kid-0.7.1/setup.py -q bdist_egg --dist-dir /tmp/easy_install- 
error: SandboxViolation: mkdir('/Users/ben/.python-eggs', 511) {}

The package setup script has attempted to modify files on your system
that are not within the EasyInstall build area, and has been aborted.

This package cannot be safely installed by EasyInstall, and may not
support alternate installation locations even if you run its setup
script by hand.  Please inform the package's author and the EasyInstall
maintainers to find out if a fix or workaround is available.

Is this a new restriction that kicked in?


More information about the Distutils-SIG mailing list