[Distutils] (no subject)

Phillip J. Eby pje at telecommunity.com
Tue Nov 21 19:34:27 CET 2006

At 06:05 PM 11/21/2006 +0100, Philippe Normand wrote:
>When I run that on a fresh checkout of my project (no build/ dir):
>python setup.py install -O1 --skip-build --root tmp/
>I get a nice tmp/usr/lib/python2.4/site-packages/mypackage.egg/
>directory (zip_safe set to False in setup()).

This appears to be a bug.  You should not be getting a .egg/ directory 
here, only a .egg-info/.

>  Then when I run :
>python setup.py build
>It creates a build/ directory as expected. Now if I run the first
>command again, the packages internal to the egg are installed directly
>in tmp/usr/lib/python2.4/site-packages/ ...

This is the correct behavior when using install --root; the use of --root 
forces setuptools into a backward-compatible mode to work with system 
packaging tools such as RPM.

>Is this a bug or a feature? I reproduce it with 0.6c2 (on Fedora Core 6)
>and 0.6c3 (on Ubuntu Edgy) versions of setuptools.

If there's a bug, it would be in the behavior you described for 
"--skip-build", although I haven't investigated it yet.  Could you check 
and make sure you weren't just seeing an .egg-info directory, rather than 
an .egg?  Thanks.

More information about the Distutils-SIG mailing list