[Distutils] Strange naming problem trying to build Enable rpm

Stanley A. Klein sklein at cpcug.org
Sat Aug 9 18:15:35 CEST 2008

I was able to build rpms for Traits, Envisage, and related packages (e.g.,
TraitsGUI) for Fedora 7.  However, when I tried to package Enable I ran
into the following problem:  The tar.gz gets built as
Enable-3.0.0.dev-r21092.tar.gz, but when the rpm packager gets called it
looks for Enable-3.0.0.tar.gz, doesn't find it, and errors out.  I've
copied a relevant part of the output below.

I modified the setup.cfg file for bdist_rpm (similarly to what I did for
the other packages I built) and have copied it below.

I don't know where the tar.gz name is set or where the name being looked
for by rpm is set.  I also don't know if this is an issue with the Enable
setup files or with distutils/setuptools, so I'm including both lists.

How do I get the proper names set?

Stan Klein

Packaging error output:

copying dist/Enable-3.0.0.dev-r21092.tar.gz ->
building RPMs
rpmbuild -ba --define _topdir
--clean build/bdist.linux-i686/rpm/SPECS/Enable.spec
error: File
No such file or directory
error: command 'rpmbuild' failed with exit status 1



tag_build = .dev
tag_svn_revision = 1

release = egg_info -RDb ''

verbosity = 0
with-doctest = 1
detailed-errors = 1
with-coverage = 1
tests =
# The following directories are included in the tests option above, when
# the line starts with '# test '.  To make changes in the tests option above
# run the script update_setup_cfg.py.
# test enthought/enable/tests
# test enthought/enable2/tests
# test enthought/kiva/tests
# test enthought/kiva/agg/tests
# Note:
#   The package enthought.enable2 is a proxy to enthought.enable and
#   the tests in 'enthought/enable2/tests' are testing this proxy.

optimize = 1

doc_files = docs/  examples/  README.txt  LICENSE.txt

More information about the Distutils-SIG mailing list