[Distutils] [Enthought-dev] Strange naming problem trying to build Enable rpm

Dave Peterson dpeterson at enthought.com
Mon Aug 11 19:51:33 CEST 2008

Stanley A. Klein wrote:
> I was able to build rpms for Traits, Envisage, and related packages (e.g.,
> TraitsGUI) for Fedora 7.  However, when I tried to package Enable I ran
> into the following problem:  The tar.gz gets built as
> Enable-3.0.0.dev-r21092.tar.gz, but when the rpm packager gets called it
> looks for Enable-3.0.0.tar.gz, doesn't find it, and errors out.  I've
> copied a relevant part of the output below.

I'm not sure what's happening here since the setup.cfg's for the ETS 
projects should all be pretty close to the same on this issue.   Are you 
doing a "setup.py release bdist_rpm"?  i.e. using the release alias?  If 
not, that's the source of the problem.

BTW: Are you checking in your changes to setup.cfg's?  If you don't have 
privileges, I can make these changes so just send me a patch, set of 
modified setup.cfgs, or instructions on what to do to reproduce your 

-- Dave

More information about the Distutils-SIG mailing list