[Distutils] PEP 376 comments

Paul Moore p.f.moore at gmail.com
Mon Jun 8 17:35:22 CEST 2009

2009/6/8 Tarek Ziadé <ziade.tarek at gmail.com>:

> Mmm, that's my frenglish, Sir  ;)  (If you see other weird stuff
> please let me know)

Well, it's better than my French, so who am I to complain? (As
everyone knows, the English speak French by USING ENGLISH WORDS, BUT
SHOUTING... :-))

> So I guess "get_egg_info" is the shortest, proper form ?

That would be fine, yes. (Though I have a sneaking suspicion that I
saw one place which had both _info and _infos, with the _infos form
being the way of getting multiple copies of the things that _info gets
one of. That's harder to deal with - I'll have a look and see if I can
find the place I mean.)


2009/6/8 Ronald Oussoren <ronaldoussoren at mac.com>:
> The thingy we're getting is called an "EggInfo", which would IMHO mean that
> "get_egg_infos" is technically the correct name for something that returns a
> list of them. I'd interpret the singular form as a function that returns one
> EggInfo object.

That's the place I mean. But I'm not sure I like the idea of calling
it an "EggInfo". I'll see if I can think of a better name (but not
being familiar with the domain, I'm not sure I'll be able to). If it
has to be an "EggInfo", then you shouldn't break it with underscores -
so you have

    get_egginfo - get an EggInfo object from wherever
    get_egginfos - get a list of EggInfo objects

(and make sure that the invented term EggInfo is defined somewhere
before it gets used here).


More information about the Distutils-SIG mailing list