[Distutils] PEP 376 comments

P.J. Eby pje at telecommunity.com
Mon Jun 8 23:14:57 CEST 2009

At 04:35 PM 6/8/2009 +0100, Paul Moore wrote:
>2009/6/8 Ronald Oussoren <ronaldoussoren at mac.com>:
> > The thingy we're getting is called an "EggInfo", which would IMHO mean that
> > "get_egg_infos" is technically the correct name for something 
> that returns a
> > list of them. I'd interpret the singular form as a function that 
> returns one
> > EggInfo object.
>That's the place I mean. But I'm not sure I like the idea of calling
>it an "EggInfo". I'll see if I can think of a better name (but not
>being familiar with the domain, I'm not sure I'll be able to).

FWIW, pkg_resources uses "Distribution", and it has functions such as 

More information about the Distutils-SIG mailing list