[Idle-dev] re: Leaving subprocesses hanging

Arthur ajsiegel at optonline.net
Sun Dec 19 15:09:23 CET 2004

John writes -

>This seems to work fine on IDLE 1.03-1.04. I've been working with it for 
>a couple days and have not noticed any problems. Unfortunately, last 
>night I tried the same fix on IDLE 1.1, and I ran into some problems. 
>Has the subprocess code undergone significant revision from 1.04 to 1.1?

Is there a possibility that the issue is differences in the versions of
tcl/tk against which it is running, rather than in changes in Idle .

It is known that threading related code that worked against 8.3 breaks under
8.4 as tcl seems to have changed its own threading model. There is some
writing out there by Martin v. Löwis about this change in tcl's model and
the changes it necessitated in Python's tkinter code. Unfortunately I can't
seem to trace my steps back to it right now. 

Is it reasonable to suspect there is relationship here somewhere with

Not that knowing that gets us anywhere in particular, but it might contain a

Are you running IDLE 1.03 against the same tcl/tk versions as you are
running IDLE 1.1?


More information about the IDLE-dev mailing list