[Idle-dev] IDLE shortcut on Windows XP (was<Tutor> Re: XP and python 2.4, some progress)

Kurt B. Kaiser kbk at shore.net
Wed Jan 12 23:55:41 CET 2005

Jim Sizelove <sizelji at insightbb.com> writes:

> Jeffrey Thomas Peery wrote:
>> I wasn.t able to get the IDLE started in windows XP. I had it
>> working then I upgraded to 2.4, then it didn.t work so I switched
>> back to 2.3, still didn.t work so I.m back to 2.4.  I did some
>> looking around and I was able to get the IDLE started by setting the
>> shortcut on my desktop to:
>>  *C:\Python24\python.exe C:\Python24\Lib\idlelib\idle.pyw .n*
>>  Not sure what this does. But is seems to get it going. What is
>> going on here? 

This is a bug which occurred at 2.4.  It is fixed in 2.4.1, due out
in a few days.

See item #2 on this  page for the workaround to fix the shortcut:


>> Also I get a console that appears with this message -
>> I have no idea what it means:
>>  *Warning: configHandler.py . IdleConf.GetThemeDict . problem
>> retrieving theme element .builtin-background.*
>> *For theme .Jeff.*
>> *Returning default value: .#ffffff.*
>>  Anyhow if anyone can explain what is going on here I would
>> appreciate the help. and is there anyway to get the IDLE icon in
>> my windows start menu to work?

Apparently you customized the Highlighting Themes.  There was a change
between 2.3 and 2.4 which added a builtin-background (and foreground)
selection.  That allows you to have a black background, which some
people like.

If you customized Highlighting, a config-highlight.cfg file was
created in your .idlerc/ (the IDLE personal configuration directory
which lives in your home directory).  When 2.4 tried to load it, it
found that the new builtin-background item was missing and errored
out.  This is a bug in IDLE.

See Python Bug # 1080387.

The simplest thing to do is delete the config-highlight.cfg file
from your .idlerc directory and restart IDLE.

If the theme you made was really complicated, see the patch at the
bottom of the aforementioned Bug.  The marked lines in the patch
should be added in the proper locations in your config-highlight.cfg,
in each theme.

>> Ok thanks for the help!  Jeff
>> ------------------------------------------------------------------------
>> _______________________________________________ Tutor maillist -
>> Tutor at python.org http://mail.python.org/mailman/listinfo/tutor
> I had a similar problem when I installed ActivePython 2.4 on my
> Windows XP notebook.  ActiveState does not include a shortcut to IDLE,
> but when I right-click on any file ending with .py, "Edit with IDLE"
> is one of the menu items.  This menu item did not work.
> After much looking around and trying different things, I eventually
> made a slight change to the PY extension in Folder Options/File Types.
> The command for the "Edit with IDLE" action looked like this:
> "C:\Python24\pythonw.exe" "C:\Python24\Lib\idlelib\idle.pyw"-n -e "%1" %*
> There was no space between the "idle.pyw" and the "-n".  Once I
> inserted a space, the shortcut menu item worked great.  I wonder if
> the space is also missing in the shortcut for IDLE in the Python 2.4
> from python.org.  Does someone using the standard python 2.4
> distribution on Windows XP want to check this out?

This would be an ActivePython problem. The spaces are present in the
official release.

Check your PYW extension, also.


More information about the IDLE-dev mailing list