[IPython-dev] WxIpython Linux hell :) was RE: wxIPython 0.6 (Multithreaded and current bug list flushed)

Laurent Dufréchou laurent.dufrechou at gmail.com
Wed Dec 12 18:43:04 EST 2007

Hi Prabhu,

I've just installed all the things on my debian.
First of all, ouch!
What a difference! On linux it is unusable!
As you said text is black (solved now), there is an issue with locale:
Can you try locale.getpreferredencoding() and tells if you've got a result?
(here on my debian the current command works.. :( )

There is a lot focus loosing problem, and backspace make loose the focus anf
widget go on the top line!!!
And ho yes... stdin/out is redirected to console...

Most of problem I has solved on windows have not been solved on linux...
Will work on it.
Excuse me to have delivered a so poor linux version...

More news for next week ;)


-----Message d'origine-----
De : Prabhu Ramachandran [mailto:prabhu at aero.iitb.ac.in] 
Envoyé : mercredi 12 décembre 2007 13:50
À : Laurent Dufrechou; IPython-dev at scipy.org
Objet : Re: [IPython-dev] wxIPython 0.6 (Multithreaded and current bug list

Laurent Dufrechou wrote:
> Hi Prabhu,
>> When I run wxIPython.py, I run into the following.
>>  1. I can't see what I type, altho you have the FG set to WHITE it 
>> renders it black.  So unless I change the BG (in ipython_view.py) to 
>> something else that is light I can't see the cursor or any test I type.
> Hum seems to be a GTK problem with wx. It is probably handled differently.
> I'll launch my debian machine to check this.
> So foreground is not well set...
> Can you (while in black) do an error like "a"+enter at startup and tells
> if traceback appears in color?

Yes, the traceback is in color and seems to render OK.

If I change the bg to white and fg to black things are better.  BTW, I 
can see output text just fine, just the input line is broken.

> Ouch, it's a locale problem. In fact in some point of the code I try to
> detect the local used on the system, and in your case, it has not been
> detected, and set to None.
> Locale is set line 108:
> #we replace IPython default encoding by wx locale encoding
> self._IP.stdin_encoding = locale.getdefaultlocale()[1]
> Anyway, if you want to continue to try the app, just comment this line.

Ahh, cool, this fixes it and I can use Python.  However, I just did this:

import string

and get a core dump!  Otherwise if I do this:


I get the help on the terminal and not on the wx shell.  If I do !ls for 
example the output is listed on the shell I launched the wxIPython shell 
from.  If I hit tab, I get completion (on the wx widget) but I also 
loose keyboard focus.

These sound like small linux specific issues.

> Can you please send me the result of: 
> Import locale
> print locale.getdefaultlocale()?

In [1]: import locale

In [2]: print locale.getdefaultlocale()
(None, None)


More information about the IPython-dev mailing list