[IPython-dev] wxIPython

Laurent Dufréchou laurent.dufrechou at gmail.com
Thu Dec 13 11:03:52 EST 2007

Yes, i've developped on windows only, and linux version is quite buggy!
I've currently solved the black on black
(self.setForegroundColor(self.default_coloretc...) and another issue with
Still missing focus loss on keyboard input and stdin/out redirection
Thanks for your report.

By the way, how about the speed?
I've tried on linux in my virtual machine and it looks like very slow on my
Have you noticed such problem???

-----Message d'origine-----
De : ipython-dev-bounces at scipy.org [mailto:ipython-dev-bounces at scipy.org] De
la part de Stefan Reichör
Envoyé : jeudi 13 décembre 2007 16:07
À : ipython-dev at scipy.net
Objet : Re: [IPython-dev] wxIPython

"Laurent Dufrechou" <laurent.dufrechou at free.fr> writes:

The wxIpython shell is really great. Thanks to all involved.

> Hi guys,
> Here is my last version.
> I've removed the bug with '?' and probably also autocompletion.
> Feel free to report any other bugs.
> It doesn't support all the functions of true ipython shell but it's I
> it's a good start.
> I need now to do some cleaning, comments etc...
> Current boring unsolved issue:
> 'Ls' command result is  written in console not into the widget ?_?
> If you really need ls just do... __IP.system("dir")
> Or whatever your os need :)
> How and crlc+c isn't supported... so don't write an infinite loop !
> Any comment, other bug report welcome.
> Cheers,
> Laurent
> ### known bug:
> # - currently WxConsoleView is a wx.Panel, can we change it to
> # - autoindent doesn't work 
> # - I must find a way to handle crtl+c with a os.fork() in case the
> do an infinite loop
> #   while (1):
> #     a=1
> # - 'pass' key when call make the interpreter to stop current multiline
> command
> #   class a:
> #     def b():
> #       pass
> #     def c():
> #   --> syntax error '):'
> # - some color glitch if userr click in a prompt color zone and start to
> write text.
> # - 'ls' command don't work (and probably all external commands)

I tried it on Windows. The ls command and other external commands are
working for me.

On Linux, ls does not work as intended. And I have another (bigger)
problem: The input text is shown as black on black. Setting
self.default_text_color does not work on startup. When I hit tab, the
correct color is applied. However, On the next input line, it starts
again with black on black.

I changed the default background to white to have white on black ;-)

Another problem with my linux version is, that I have to set the cursor
manually after entering a line. Otherwise all input is ignored.

I use the following wx version:
In [4]: import wx
In [5]: wx.version()
Out[5]: ' (gtk2-ansi)'


IPython-dev mailing list
IPython-dev at scipy.org

More information about the IPython-dev mailing list