[Ironpython-users] Use 'ipy.exe' to run tests in Robot framework

Jeff Hardy jdhardy at gmail.com
Wed May 7 09:57:21 CEST 2014

On Tue, May 6, 2014 at 2:31 PM, Harshal Marne <hmarne at gmail.com> wrote:
> Setup details:
> System: windows 2008
> Robot framework: 2.8.4
> Python 2.7.6
> IronPython 2.7
> Task:
> To run tests based on (.dll created out of c# code) as described in
> https://code.google.com/p/robotframework/wiki/HowToUseCSharp
> Issue:
>   File "C:\Python27\Lib\site-packages\robot\utils\__init__.py", line 44, in
> <module>
>   File "C:\Python27\Lib\site-packages\robot\utils\etreewrapper.py", line 46,
> in <module>
> ImportError: No valid ElementTree XML parser module found
> Press any key to continue . . .

I wonder if robot is picking up the Python ElemtTree implementation
instead of IronPython's (we patch ETree to not require pyexpat). Try
copying the robot files into IronPython's Lib/site-packages and see if
anything changes.

> Work-around tried:
> As described in
> https://code.google.com/p/robotframework/issues/detail?id=154 copied
> https://svn.code.sf.net/p/fepy/code/trunk/lib/pyexpat.py and placed it in
> C:\Program Files (x86)\IronPython 2.7\Lib as expat.py
> Queries:
> 1) Is the fix in workaround being tried is correct or not?

That's really old code, so I don't know if it has enough to run ElementTree.

> 2) If not does any idea if this issue (
> http://ironpython.codeplex.com/workitem/31923, 21047 ) will get fixed.

I don't think anyone is currently working on it. Alex did some work
that I think is in a GH fork somewhere that could be a starting
(resuming?) point.

- Jeff

More information about the Ironpython-users mailing list