[Mailman-Developers] Uncaught runner exception: 'generator' object has no attribute 'insert'

Pavel Chytil pchytil@ece.ogi.edu
Mon, 26 Nov 2001 10:00:54 -0800


I am new to mailman, so bear with me. I have downloaded mailman-2.0.7 which
works fine, than I have tried mailman 2.1 (also from cvs), and getting error
message below in error log whenever I try to send email to
mailman-request@asp.ogi.edu with word help in Subject line (I have tried also
word help in body of message without any luck).

Nov 25 16:24:47 2001 (11789) Uncaught runner exception: 'generator' object has
no attribute 'insert'
Nov 25 16:24:47 2001 (11789) Traceback (most recent call last):
  File "/work/mailman/Mailman/Queue/Runner.py", line 104, in __oneloop
    self.__onefile(msg, msgdata)
  File "/work/mailman/Mailman/Queue/Runner.py", line 152, in __onefile
    keepqueued = self._dispose(mlist, msg, msgdata)
  File "/work/mailman/Mailman/Queue/CommandRunner.py", line 61, in _dispose
    mlist.ParseMailCommands(msg, msgdata)
  File "/work/mailman/Mailman/MailCommandHandler.py", line 198, in
    lines.insert(0, SPACE.join(subjcmd))
AttributeError: 'generator' object has no attribute 'insert'

What am I doing wrong?