[Mailman-Users] problem installing on FreeBSD 3.0-RELEASE, Python 1.5.1, Apache, sendmail

james at perforce.com james at perforce.com
Tue Jul 13 20:07:35 CEST 1999

First of all, let me say that I think Mailman (and Python!) are the
greatest things since sliced bread.

I do, however, have a 1.0rc3 install problem which I'm at a loss to solve.
The web interface works fine but I just can't send email to a test
list - I have the dreaded "unknown mailer error 2" blues.

Before you say "check the gid used by sendmail", well, I have.  To prove
what it's using I added an alias

gidtest: "|/usr/bin/id >/tmp/gidtest"

then sent mail to gidtest.  The result is:
cat /tmp/gidtest
uid=1(daemon) gid=1(daemon) groups=1(daemon)

I've checked /var/log/messages and I see nothing pertinent there. Note
that for some reason when I first installed mailman daemon was in
group "guest" with gid 31.  I changed the passwd entry to put daemon in
group daemon (gid 1).  I then tried the email, but it bounced as before.  
I tried reinstalling (make clean, configure, make install) Mailman
specifying --with-mail-gid=1 but I still got bounces.  I tried completely
deleting everything, starting over with 'tar xvfz mailman.tar.gz' and
installing, again with --with-mail-gid=1 but I still get bounces.

I have installed Mailman successfully on another FreeBSD machine using
Apache and sendmail and have been using it for quite a while (it's 1.0b6
vintage, or thereabouts).  That makes it all the more frustrating that I
can't get it to work on this other machine.  They're both running FreeBSD
3.0-RELEASE, although the other machine was running 2.2 when I installed
Mailman.  I think both machines are running sendmail 8.9.1

I noticed a couple of glitches during the install.  The INSTALL
instructions mention 'owner-mailman' at one point but 'mailman-owner'
everywhere else.  There is a paragraph 'Note: Do *not* change HOME_DIR
or MAILMAN_DIR ...' which doesn't seem to apply any more (I couldn't
find MAILMAN_DIR anywhere).  I could not find any .gif files anywhere -
the misc directory doesn't seem to have been installed (should it have
been, or should the instructions be different?).  Lastly, and most
importantly, bin/check_perms fails with a stack traceback:
Traceback (innermost last):
  File "bin/check_perms", line 160, in ?
  File "bin/check_perms", line 76, in checkall
    os.path.walk(mm_cfg.PREFIX, checkwalk, STATE)
  File "/usr/local/lib/python1.5/posixpath.py", line 253, in walk
    walk(name, func, arg)
  File "/usr/local/lib/python1.5/posixpath.py", line 253, in walk
    walk(name, func, arg)
  File "/usr/local/lib/python1.5/posixpath.py", line 247, in walk
    func(arg, top, names)
  File "bin/check_perms", line 52, in checkwalk
    except OSError, (code, msg):
NameError: OSError

I tried copying the misc directory over and rerunning check_perms and I
Traceback (innermost last):
  File "bin/check_perms", line 164, in ?
  File "bin/check_perms", line 128, in checkadminpw
    mode = statmode(adminpw)
  File "bin/check_perms", line 39, in statmode
    return os.stat(path)[ST_MODE]
os.error: (2, 'No such file or directory')

Any help appreciated!

James Strickland
Perforce Software Technical Support
support at perforce.com
510 864-7400

More information about the Mailman-Users mailing list