[Mailman-Users] mailman-owner,aaryn at ag.arizona.edu,lab

Aaryn Olsson aaryn at Ag.Arizona.Edu
Tue Aug 1 01:05:32 CEST 2000

Dear mailman-users,

I am upgrading from mailman-1.1 to 2.0beta4 and am having a very difficult 
and confusing time getting mailman to behave properly.

I issued the following commands to install mailman from the source directory:
	./configure --with-mail-gid=mailman --with-cgi-gid=nobody 
	sendmail stop
	make install
	sendmail start

I successfully created a list (abc_test) and subscribed myself.  I received 
a message indicating the fact (See Item 1 below), but was unable to receive 
messages sent to the list.

Item 1:
 From my inbox:
	Date: Mon, 31 Jul 2000 14:49:45 -0700 (MST)
	From: abc_test-request at Ag.Arizona.Edu
	To: aaryn at Ag.Arizona.Edu
	Subject: Welcome to the "Abc_test" mailing list

	Welcome to the Abc_test at Ag.Arizona.Edu mailing list!

When I send a message to the list, nothing happens.  No errors are produced 
in any logs that I know of, no bounces are sent to myself as list 
subscriber nor as mailman-owner (See Item 2).

Item 2:
Directory of mailman logs (note no errors, and no activity since the 
successful list subscription)
	-rw-rw-r--   1 root     mailman        0 Jul 31 14:50 error
	-rw-rw-r--   1 root     mailman      150 Jul 31 14:49 smtp
	-rw-rw-r--   1 root     mailman       64 Jul 31 14:49 subscribe

A message is logged to syslog that indicates the mail was sent (See Item 3).

Item 3:
 From sylog:
	Jul 31 15:26:59 ag sendmail[28557]: [ID 801593 mail.info] 
PAA28554: 	to="|/home/guest/mailman/mail/wrapper post abc_test", 
delay=00:00:01, 	xdelay=00:00:00, mailer=prog, stat=Sent

But it just disappears.  No messages pertaining to mailman are held in the 
mail queue (We use sendmail 8.9.3).  When I run mail/wrapper post from the 
command line, I get the error "Failure to exec script. WANTED gid 259, GOT 
gid 0.  (Reconfigure to take 0?)."  When I run bin/check_perms, I get the 
message, "No problems found."  This is what the permissions are on my mail 
and scripts directory:

	ag: /home/guest/mailman/ > ls -al mail
	total 76
	drwxrwsr-x   2 root     mailman      512 Jul 31 15:25 ./
	drwxrwsr-x  17 mailman  mailman      512 Jul 31 14:49 ../
	-rwxr-sr-x   1 root     mailman    36780 Jul 31 15:25 wrapper*

	ag: /home/guest/mailman/ > ls -al scripts
	total 54
	drwxrwsr-x   2 root     mailman      512 Jul 31 15:25 ./
	drwxrwsr-x  17 mailman  mailman      512 Jul 31 14:49 ../
	-rw-r--r--   1 root     mailman     1507 Jul 31 15:25 answer_majordomo_mail
	-rw-r--r--   1 root     mailman     9515 Jul 31 15:25 driver
	-rw-r--r--   1 root     mailman     2351 Jul 31 15:25 mailcmd
	-rw-r--r--   1 root     mailman     2502 Jul 31 15:25 mailowner
	-rw-r--r--   1 root     mailman     1537 Jul 31 15:24 paths.py
	-rw-r--r--   1 root     mailman      285 Jul 31 15:26 paths.pyc
	-rw-r--r--   1 root     mailman     3302 Jul 31 15:25 post

Okay, So I decide to reconfigure like it suggests: (Reconfigure to take 0?)

So I go back to the mailman source and type the following commands:

	rm -rf /home/guest/mailman/*
	./configure --with-mail-gid=0 --with-cgi-gid=nobody 
	/etc/rc2.d/S88sendmail stop
	make install
	/etc/rc2.d/S88sendmail start
	echo hi | mail abc_test

Now, at least, the bounce message comes to mailman-owner, but it says this:
Failure to exec script. WANTED gid 0, GOT gid 259.  (Reconfigure to take 
259?)554 "|/home/guest/mailman/mail/wrapper post abc_test"... unknown 
mailer error 2

What the *$%# is going on here?

--sound of someone screaming, the telltale rain of a man pulling out his hair--

Sincerely yours,
Aaryn Olsson
University of Arizona
College of Agriculture
System Administrator

More information about the Mailman-Users mailing list