[Mailman-Users] Archival failure (HyperArch?)

Dan Mick Dan.Mick at West.Sun.COM
Thu Aug 31 06:57:14 CEST 2000

> I've just set up a 2.0b5 server.  I have all the list functionality
> working right, as far as I know, but there are no HTML archives.  The
> mbox file is being updated -- I can see the messages in there -- but
> it's not being converted to HTML.
> "arch" is being run, though.  When I run it manually, I get:
>   Pickling archive state into /var/mailman/archives/private/list/pipermail.pck
> And the web stuff says (no matter whether I run arch directly, or let
> Mailman do it):
>   Currently, there are no archives.

'arch' is not normally run to archive mail; it's merely a "rebuild"
convenience command.  Mails are normally archived internally by
invoking methods in Archiver.py, specifically (usually) ArchiveMail().

However, diagnosing 'arch' would be a good thing to do.
> I know I have a weird installation, but I don't know where to begin
> debugging this -- not enough sense of HyperArch and pipermail's guts.
> Any pointers?

My standard recommendation: can you run arch under some sort of
system-call-trace utility, and watch what files it opens (or tries)
and what it tries to write?  Solaris: truss  Linux: strace

More information about the Mailman-Users mailing list