[Mailman-Users] Cannot seem to get it working

David Koopman dave at thewebmark.com
Wed Dec 27 20:41:59 CET 2000

I have mailman installed on my machine:


and I have set up a mailing list correctly:  mailman and php

It was working for a couple days, I have been able to subscribe members,
send e-mails to the list, e-mail subscription was working, everything worked

Now, however, all of a sudden, mailman will not send any e-mails out.  In
frustration, I have removed the list altogether with rmlist and then
recreated it.  Still it will not work.

The last thing I did was send an e-mail to: mailman-request at twmtest.com with
the word subscribe in the subject and body.
In my /var/log/maillog, the last entry is this:
Dec 27 12:15:59 linux-server postfix/local[1003]: 848B5705FB:
to=<mailman-request at twmtest.com>, relay=local, delay=1, status=sent
("|/home/mailman/mail/wrapper mailcmd mailman")

That looks good.  My aliases file contains these lines (I have ran
newaliases afterwards too):
mailman: "|/home/mailman/mail/wrapper post mailman"
mailman-admin: "|/home/mailman/mail/wrapper mailowner mailman"
mailman-request: "|/home/mailman/mail/wrapper mailcmd mailman"
mailman-owner:   mailman-admin

I haven't changed any configuration, it just stopped working.  It simply
doesn't work.  Can anyone help?  What should I look at?  If I send an e-mail
to:  mailman at twmtest.com -- it appears to work just fine, but no e-mails are
sent and no administrative tasks are created!!  If I send an e-mail to
mailman-request at twmtest.com  --  again, it is not returned, but it doesn't
respond to the sender.  It is acting like mailman is accepting the mail,
then discarding it with no error returned to the sender.  My maillog file
looks totally normal, so something is going wrong with mailman, not postfix,
as far as I can tell.  I cannot believe it was working yesterday, then all
of a sudden stopped working.  I have even tried rebooting the server with
'shutdown -r now' just to see if that would help and it didn't.  Maybe it is
holding all of the stuff in a queue and it's waiting to process it?  If so,
how do I check that and turn that option off so it processes everything as
soon as possible?

Thank you for considering,

Dave Koopman

More information about the Mailman-Users mailing list