[Mailman-Users] Strange problems

Nathan Stratton nathan at robotics.net
Tue Feb 29 06:19:18 CET 2000

Ok, I am having some strange problems with my mailman server. This
started when I move from FreeBSD to Linux. I am currently running Mailman
1.1 on Redhat 6.1. 

Ok, the first thing is that when I run check_bd I get a error that the db
files are messed up. I looked at them and notice they are owned by
mail.mailman. It is odd, I change it to mailman.mailman and it works fine,
but it gets changed back to mail.mailman when someone sends mail to the

The next problem is that mail is not sent to the lists, if I look in error
log file I get:

Feb 28 23:27:04 2000 post: Traceback (innermost last):
post:   File "/home/mailman/scripts/post", line 73, in ?
post:      mlist.Post(msg, approved=fromusenet)
post:   File "/home/mailman/Mailman/MailList.py", line 1329, in Post
post:      self.ArchiveMail(msg)
post:   File "/home/mailman/Mailman/Archiver/Archiver.py", line 206, in
post:      lock.lock()
post:   File "/home/mailman/Mailman/LockFile.py", line 245, in lock
post:      os.unlink(self.__tmpfname)
post: OSError :  [Errno 2] No such file or directory:

The last problem is that I cant run arch. When I run it it just sits there
forever and does not do anyting. If I hit control-C I get a lock file

So, how do I fix my lockfile and permissions errors? 

BTW when I run check_perms everything checks out.

Nathan Stratton
nathan at robotics.net

More information about the Mailman-Users mailing list