[Mailman-Users] problems installing

Harold Paulson haroldp at sierraweb.com
Fri Oct 27 21:25:39 CEST 2000


Thanks much for responding.  Any help, even just pointing me in new 
directions to look, is very much appreciated.

>Have either of you checked other logs, like error?

Yes.  Nothing gets sent to error, in my case.

>Can either of you run qrunner under something like truss or strace?
>(on Solaris, truss python ~mailman/cron/qrunner will run qrunner once under
>system-call tracing, so you can see what it's doing)

reading the man page for 'ktrace' now...

>Running python -v ~mailman/cron/qrunner might be worth a try too

The first time I tried running python -v, it hung after doing 
something with "MultiLogger.py", like this:


I killed that and tried again a bit later, and it seemed to get 
farther, with this output:


and it looks hung at that point, or still in the debugger or 
something?  Nothing really jumps out at me in the output, but I'm not 
a python programmer.

	- H

>Harold Paulson wrote:
>>  Rodrigo,
>>  We seem to be having similar problems, and no one is really making
>>  any good guesses.  One weird thing that I noticed is that if I kill
>>  all current qrunners, and remove all locks:
>>          killall qrunner; rm ~mailman/locks/*
>>  then a new qrunner will pop up in a minute (from cron).  If I 
>>watch it in top:
>>          top -qUmailman
>>  It uses a little CPU for a minute or two, and then slowly dies off to
>>  0% CPU usage.  It never does anything that I can see, and runs for a
>>  very long time.
>>  Could I have a corrupted msg that is hanging qrunner?  The biggest
>>  file in qfiles is about 6k, so it's not a size issue...
>>          - H
>>  WARNING: 'killall' may work very differently on various unix flavors.
>>  Don't do that on a Solaris box!
>>  >>  On Oct 26, 2000 at 12:53, Rodrigo Moya wrote:
>>  >>
>>  >>  >I've installed mailman on a RH 6.2 machine. The POP3 server in that
>>  >>  >machine works perfectly, the messages I send to the mailing lists are
>>  >>  >logged in the logs/post file. But, no mail goes to the list members.
>>  >>
>>  >>  POP3? SMTP would be what you want to check.
>>  >>
>>  >>  Some guesses...
>>  >>
>>  >>  Check mailman's crontab. The queue runner should be a cron job, AIUI.
>>  >>
>>  >it seems ok. The qrunner binary is set to be executed every 
>>minute (at least
>>  >this is what "crontab -u mailman -l" says.
>>  >
>>  >And no /etc/cron.{allow,deny} exists, so mailman should be 
>>allowed to run cron
>>  >jobs.
>>  >
>>  >And "tail -f logs/qrunner" shows 2 log messages every minute. So, 
>>  >related to cron seems to work.
>>  >
>>  >But still, list members don't get any message from the lists.
>>  >
>>  >What else could be?
>>  >
>>  >cheers
>>  Harold Paulson                  Sierra Web Design
>>  haroldp at sierraweb.com           http://www.sierraweb.com
>>  VOICE: 775.833.9500             FAX:   810.314.1517
>>  ------------------------------------------------------
>>  Mailman-Users maillist  -  Mailman-Users at python.org
>>  http://www.python.org/mailman/listinfo/mailman-users

Harold Paulson                  Sierra Web Design
haroldp at sierraweb.com           http://www.sierraweb.com
VOICE: 775.833.9500             FAX:   810.314.1517

More information about the Mailman-Users mailing list