[Mailman-Users] archiver errors

Chris Hedemark hedemark at bops.com
Mon Sep 25 15:58:03 CEST 2000

post(30891):     self.__archive_to_mbox(msg)
post(30891):   File "/home/mailman/Mailman/Archiver/Archiver.py", line 160,
in __archive_to_mbox
post(30891):     post.SetHeader('Date', time.ctime(time.time()))
post(30891): AttributeError: SetHeader
Sep 24 20:59:51 2000 admin(31661): Traceback (innermost last):
admin(31661):   File "/home/mailman/Mailman/Archiver/Archiver.py", line 204,
in ArchiveMail
admin(31661):     self.__archive_to_mbox(msg)
admin(31661):   File "/home/mailman/Mailman/Archiver/Archiver.py", line 160,
in __archive_to_mbox
admin(31661):     post.SetHeader('Date', time.ctime(time.time()))
admin(31661): AttributeError: SetHeader

The above is a tail of my ~/logs/error which shows some problems I'm having
relating to the archives.  We've been running for oh close to a month now
and haven't gotten any archives yet it seems.  I checked the FAQ and online
documentation and didn't see any reference to this as a known problem.

I'm running the latest Mailman on a Red Hat 6.2 x86 system with all of the
latest update RPM's from Red Hat.

Has anyone seen & gotten around this before?  I'm not any sort of programmer
so really have no idea how to go about fixing this.  Thanks!

Chris Hedemark
System Administrator
Billions of Operations Per Second, Inc.
6340 Quadrangle Drive, Suite 210
Chapel Hill, NC 27514
Phone: (919)403-6757 x139
Fax: (919)402-9442
email: hedemark at bops.com <mailto:hedemark at bops.com>
"What a cruel reflection that a rich country cannot long be a free one." -
Thomas Jefferson

More information about the Mailman-Users mailing list