[Mailman-Users] Admin attempts hang (self healing overnight)

John W Baxter jwblist at olympus.net
Tue Apr 3 16:33:27 CEST 2001

Mailman 2.0 on RedHat Linux 6.2 (6.2 updated with latest known from RH).

We had a list yesterday (Apr 2) afternoon for which any attempt to access
the Admin pages timed out in the web browser (variety of browsers and
people trying).  The timeout was after clicking a link which would have
gone to a page for logging in as Admin.

I found several lock files related to the list (seemingly one "master" with
a short name, and many session locks (with a PID? at the end of the name).
Removing those did not clear up the problem.  I left the new locks which
resulted from the later trials in place.

Waited overnight to work on it ("you get worried when it's Monday and it's
already been a long week")...the problem had healed itself by morning.  It
had not self-healed in the evening after several hours.

The main list admin...a knowledgable person...sent me this description of
the actions (of another admin) leading up to the problem:

[She] was subscribing some new people.  Thought she'd check to see if
they were already subscribed. She left the names in box WITHOUT
clicking submit, and went to check the membership list. They weren't
subscribed. When she came back to the main membership page the names
were gone, so she typed names in again, and *did* hit submit-- which
generated a message saying that the names were already on subscribed.
When she tried to go back to the main membership management screen
she couldn't get there and when she tried to logout, the machine just
hung.   Subsequent efforts to log back in have failed (as you and I

John Baxter   jwblist at olympus.net      Port Ludlow, WA, USA

More information about the Mailman-Users mailing list