[Mailman-Users] set gid didn't work?

Amanda arandall at auntminnie.com
Tue Jun 5 18:43:29 CEST 2001

Thank you, Nigel, for the suggestion. :-)

Unfortunately...  it apparently won't configure that way. When I run
./configure --with-mail-gid=401
it says:
[ No existing group found for the mail_wrapper program. This is the group that your mail
delivery agent runs under, and uses to run filter programs. You might want to specify an
existing group with the --with-mail-gid configure option. Please see your mail agent's
documentation, and the install file for details. ]

Well ... in the category of other potentially helpful information, when you install
qmail you make two groups (not eight, as previously suggested): qmail and nofiles. The
mail components appear to run from the qmail group with the various qmail uids. Neither
qmail nor nofiles has a gid of 401. To the best of my ability to determine, 401 doesn't

The readme.qmail suggests setting it to the GID of qmail, mailman, or nofiles. Tried all
three. They all give me failure_to_exec_script:_wanted_gid_[whichever],_got_gid_401. In
fact, so far, I've tried the group ids of qmail, nofiles, nobody, mail, mailman, and
website. No change except for the "wanted" gid in the log.

If it wants 401 and I can't give it 401, what do I do next? (Aside from taking it out in
the pasture and shooting it?)


[Further system info as the last time I mentioned this was several posts ago: mailman
2.0.5 on mandrake 8 with qmail 1.03, apache 1.3.20, using xinetd, and there's
very little else on the machine. It was set up for the express purpose of running

Nigel Metheringham wrote:

> As I recall, qmail hardwires a batch of its uids and gids when its
> built, so you can easily have a running qmail using group 401 with no
> group 401 defined on your system :-)
> Try
>     ./configure ... -with-mail-gid=401
>     Nigel.

More information about the Mailman-Users mailing list