[Mailman-Users] setting up new list-Cobalt RaQ4

Joe Keenan jkeenan at blkcat.com
Sun Oct 7 15:13:51 CEST 2001

I'm just guess here (never used a RaQ system), but it oocurs to me that 
the RaQ sendmail config is probably set up for no local users.  That is, 
for relaying mail only.  It's primarily intended for network attached 
storage uses, right?

So you probably need to force sendmail to attempt to do local delivery of 
the Mailman addresses.  It's probably not looking at the aliases file at 
all, since it doesn't think that it's a final delivery point.


On Saturday, October 6, 2001, at 10:50  PM, Paul wrote:

> More info I found while poking around my system:
> When I try to set up my first list-"test," it's Sendmail on the RaQ
> that doesn't seem to want to cooperate.
> When you set up a list in Mailman, it outputs a few lines which you should
> put in /etc/aliases (/etc/mail/aliases on the RaQ) for Sendmail. They look
> something like this:
> test:                    "|/home/mailman/mail/wrapper post test"
> test-admin:              "|/home/mailman/mail/wrapper mailowner test"
> test-request:            "|/home/mailman/mail/wrapper mailcmd test"
> test-owner:              test-admin
> So, I guess you're supposed to copy those into /etc/mail/aliases and run 
> the
> command
> "newaliases" from root. Done. However, I got this in Mailman's log:
> Oct 06 19:15:32 2001 (600) All recipients refused: (553, '5.3.0
> <test-admin at server2.internetforall.com>... No such user here',
> 'test-admin at server2.internetforall.com')
> I have tried completely deleting the list "test" and re-creating it, and
> doing a full reboot of the server (several times)
> Then, I had the idea: Why not make an alias file for Mailman? Majordomo 
> has
> its own alias file, found at /etc/mail/aliases.majordomo. Why not do the
> same for Mailman?
> So, I deleted the entries I put in /etc/mail/aliases, created the file (as
> root) /etc/mail/aliases.mailman, and put a line in sendmail.cf:
> O AliasFile=/etc/mail/aliases.mailman
> I ran "newaliases" and it processed aliases.mailman fine.
> However, Sendmail STILL DOES NOT want to "link" with Mailman! I get the 
> same
> errors as before, even after a full reboot!!
> Thanks,
> Paul
> ------------------------------------------------------
> Mailman-Users maillist  -  Mailman-Users at python.org
> http://mail.python.org/mailman/listinfo/mailman-users

More information about the Mailman-Users mailing list