[Mailman-Users] newbie question

Brian Noecker bnoecker at jabber.com
Wed Apr 10 22:24:02 CEST 2002

Update on this:

Seems that the problems with the "admin(21776): OSError: [Errno 1] Operation
not permitted" error stem from the following observations:

the /opt/mailman/lists and /opt/mailman/lists/test/config.db file has
permissions and ownership as such:
drwxrwsr-x    2 mailman  mailman      3072 Apr 10 13:48 test
-rw-rw----    1 mailman mailman      3392 Apr 10 13:48 config.db
-rw-rw----    1 www-data mailman      3391 Apr 10 13:47 config.db.last
-rw-rw----    1 www-data mailman      3029 Apr 10 11:47

Now, as you can see, the config.db.tmp.... files are being created everytime
I make a change that effects the config.db.  The temp file is written by the
www user and looks as if it needs to be re-written as the config.db, but
can't.  We tried chmod 777 on config.db, but no luck.  We then tried chown
www-data.mailman config.db and then it worked fine.

I don't understand why this process is failing.  We have another mailman
install that keeps the mailman.mailman permissions on config.db and works

Can anyone explain this, or how the process should work?


-----Original Message-----
From: Brian Noecker [mailto:bnoecker at jabber.com]
Sent: Wednesday, April 10, 2002 1:15 PM
To: 'mailman-users at python.org'
Subject: [Mailman-Users] newbie question

Ok, totally new to mailman, but giving it a try.  Currently I have version
2.0.9 runnig on Linux.  The install seemed to work fine.  The ./check_perms
reports things are fine.  I have mailman running as mailman, with group
mailman.  I have a web server running under a different www-data account.  

I think I have some permission issues however, for I tend to see the
following error pop up in different places.  Most notably, when a new user
signs up, they get a "Subscription results" page confirming their sign up,
but with the following at the bottom.
Content-type: text/html 
Bug in Mailman version 2.0.9
We're sorry, we hit a bug!
Please inform the webmaster for this site of this problem. Printing of
traceback and other system information has been explicitly inhibited, but
the webmaster can find this information in the Mailman error logs. 

In the logs I see:

Apr 10 12:56:55 2002 (21776) Delivery exception: 
Apr 10 12:56:55 2002 (21776) Traceback (innermost last):
  File "/opt/mailman/Mailman/Handlers/HandlerAPI.py", line 82, in
    func(mlist, msg, msgdata)
  File "/opt/mailman/Mailman/Handlers/SMTPDirect.py", line 77, in process
  File "/opt/mailman/Mailman/MailList.py", line 1339, in Lock
  File "/opt/mailman/Mailman/LockFile.py", line 266, in lock
    raise AlreadyLockedError

Apr 10 12:56:55 2002 admin(21776):
admin(21776): [----- Mailman Version: 2.0.9 -----]
admin(21776): [----- Traceback ------]
admin(21776): Traceback (innermost last):
admin(21776):   File "/opt/mailman/scripts/driver", line 96, in run_main
admin(21776):     main()
admin(21776):   File "/opt/mailman/Mailman/Cgi/subscribe.py", line 77, in
admin(21776):     mlist.Save()
admin(21776):   File "/opt/mailman/Mailman/MailList.py", line 857, in Save
admin(21776):     self.__save(dict)
admin(21776):   File "/opt/mailman/Mailman/MailList.py", line 833, in __save
admin(21776):     os.link(fname, fname_last)
admin(21776): OSError: [Errno 1] Operation not permitted
admin(21776): [----- Python Information -----]
admin(21776): sys.version    = 1.5.2 (#1, Dec 21 2000, 15:29:08)  [GCC
egcs-2.91.66 19990314/Linux (egcs-
admin(21776): sys.executable = /usr/bin/python
admin(21776): sys.prefix     = /usr
admin(21776): sys.exec_prefix= /usr
admin(21776): sys.path       = /usr
admin(21776): sys.platform   = linux-i386

I see the OSError: [Errno 1] Operation not permitted error pop up in other
places as well.

Ideas to get me started?

Mailman-Users mailing list
Mailman-Users at python.org
Mailman FAQ: http://www.python.org/cgi-bin/faqw-mm.py

More information about the Mailman-Users mailing list