[Mailman-Users] problem with custom interface

Derek Evan Mart marticus at louisville.edu
Sat Apr 13 20:48:05 CEST 2002

Why does this code fail? "Bug in Mailman version 2.0.8..."

  code from http://www.animesociety.org/test.html

  the list is located at list.marticus.org

  <? $password = "trustno1" ?>
  <FORM class="list" method="POST"
  <INPUT type="text" name="email" size="30">
  <INPUT type="hidden" name="pw" value="<? echo $password ?>">
  <INPUT type="hidden" name="pw-conf" value="<? echo $password ?>">
  <INPUT type="submit" name="email-button" value="subscribe">

admin(6509): Traceback (most recent call last):
admin(6509):   File "/home/list/scripts/driver", line 96, in run_main
admin(6509):     main()
admin(6509):   File "/home/list/Mailman/Cgi/subscribe.py", line 76, in
admin(6509):     process_form(mlist, doc)
admin(6509):   File "/home/list/Mailman/Cgi/subscribe.py", line 158, in
admin(6509):     pw  = form["pw"].value
admin(6509): AttributeError: value

It seems to work correctly when I call the program directly:

  http://list.marticus.org/mailman/subscribe/kias-announce  \

My reason for doing this is to provide an easy way for my users to
join various mailing lists from a single document. What am I doing
wrong here?

Your time spent on this matter is greatly appreciated.

Derek Evan Mart "Marticus" - Systems Programmer II
U of L - Electrical & Computer Engineering
The Marticus Project - http://www.marticus.org/
1514 3659 D057 D10C 6BE6  3E68 15BE B181 2F1F 510B
AA C4 72 14 97 6F 14 14  B3 9C BB 6E D8 71 9A 67

More information about the Mailman-Users mailing list