[Mailman-Users] more permission problems

David Gordon davidgordon at ntlworld.com
Thu Nov 28 19:21:28 CET 2002

[Sometimes I don't get a copy of my mail to this list so sorry if I
appear to be repeating...]

I've reinstalled Mailman 2.0.13 because I couldn't get it going
yesterday. I beleive I'm installing it on a machine with "Apache/1.3.23
(Unix)  (Red-Hat/Linux) mod_ssl/2.8.7 OpenSSL/0.9.6 PHP/4.1.2 FrontPage/ configured".

I have done the check_perms business. Mail doesn't get sent. One message
got through. I then auto subscribed some members. Then it all went wrong.
This is _exactly_ what happenned yesterday. Further point of information,
since doing the check_perms I can't get to the web pages. Here's what I
know, but don't understand

>Traceback (innermost last):
>  File "/home/mailman/cron/gate_news", line 222, in ?
>    main()
>  File "/home/mailman/cron/gate_news", line 198, in main
>    lock.lock(timeout=0.5)
>  File "/home/mailman/Mailman/LockFile.py", line 219, in lock
>    self.__write()
>  File "/home/mailman/Mailman/LockFile.py", line 350, in __write
>    fp = open(self.__tmpfname, 'w')
>IOError: [Errno 13] Permission denied: '/home/mailman/locks/

I have done the check_perms business ;-)

I did have to manually chmod the $prefix/cgi-bin to get my web pages for
this list working. (Stopped working since check_perms)

I have sucessfully set up another list without problems, what's my
problem really. This is the same/similar as I was having yesterday. I
have reinstalled. Have I got a duff copy of Mailman. Should I download
another copy from another location and have another attempt?


More information about the Mailman-Users mailing list