[Mailman-Users] Upgrade failure to 2.1b3

G. Armour Van Horn vanhorn at whidbey.com
Thu Oct 3 12:20:00 CEST 2002

I've been running Mailman for most of two years, going from 2.0.5 to 2.0.12+ on a
very lightly loaded K6-233. I've finally been convinced to move up. Last night I
reved RedHat from 6.2 to 7.2, installed Python2 2.2.1, and generally brought
things up to date.

I also added virtual host support to Postfix, as I have a client that wants this
on their new list. I am now hosting DNS for their domain, and mail to their domain
through the Postfix-style virtual host works.

I decided not to change the Mailman location at this time, so I used the
following  config:

./configure --with-mail-gid=99 --with-cgi-gid=99 --prefix=/home/mailman

The configure runs fine right down to the end where it tells me I don't have
Chinese Unicode support and sends me off to a location where there aren't any
files, but I don't really expect to have a lot of Chinese customers on here. It's
the next step that is stopping me:

make install runs smoothly for several minutes, but concludes with this:

> Compiling /home/mailman/Mailman/Version.py ...
> Compiling /home/mailman/Mailman/__init__.py ...
> Compiling /home/mailman/Mailman/htmlformat.py ...
> Compiling /home/mailman/Mailman/i18n.py ...
> Compiling /home/mailman/Mailman/versions.py ...
> Traceback (most recent call last):
>   File "bin/update", line 44, in ?
>     import paths
> ImportError: No module named paths
> make: *** [update] Error 1

The appropriate section in /usr/src/mailman-2.1b3/build/bin/update looks like

> import paths
> from Mailman import mm_cfg
> from Mailman import Utils
> from Mailman import MailList
> from Mailman.LockFile import TimeOutError
> from Mailman.i18n import _
> from Mailman.Queue.Switchboard import Switchboard

I tried commenting them out one at a time, but each time I just had to comment out
the next one. I blew away everything in the /home/mailman directory except the
lists, logs, and archives and got the same result. Just to be thorough, I cleaned
everything out, blew away the /usr/src/mailman-2.1b3 directory, extracted the
install files again, and there was no change. I even downloaded another copy of
the tarball.

So what am I missing?


Sign up now for Quotes of the Day, a handful of quotations
on a theme delivered every morning.
Enlightenment! Daily, for free!
mailto:twisted at whidbey.com?subject=Subscribe_QOTD

For web hosting and maintenance,
visit Van's home page: http://www.domainvanhorn.com/van/

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.python.org/pipermail/mailman-users/attachments/20021003/53246193/attachment.htm 

More information about the Mailman-Users mailing list