[Mailman-Users] moderators not getting notified & private archives not found

Matthew Kalastro mk at calcentral.com
Mon Feb 24 22:46:44 CET 2003

I just installed Mailman 2.1.1 and my users are reporting problems.  

First, list moderators are not getting notified to approve posts.  Here's the
settings for the lists I'm having problems with:
    "Action to take for postings from non-members for which no explicit action
is defined." = Hold
    "Should messages from non-members, which are automatically discarded, be
forwarded to the list moderator?" = Yes
    "Should the list moderators get immediate notice of new requests, as well as
daily notices about collected ones?" = Yes
    list administrator = mk at soe.ucsc.edu (password set)
    list moderator = mk at soe.ucsc.edu (password set)

Are there other settings that effect moderator notification?  Mail is coming in
and going out fine, and posters are getting notified their messages are held for
approval.  But moderators are not being emailed to approve non-member postings.

Second, I had to tweak Mailman/Cgi/private.py to work around a "Private archive
file not found" error.  The call to guess_type(path, strict=0) seems broken on
my install of Mailman, so here's what I used instead (from my tweaked

    # Authorization confirmed... output the desired file
#        ctype, enc = guess_type(path, strict=0)
#        if ctype is None:
        ctype = 'text/html'
        if mboxfile:
            f = open(os.path.join(mlist.archive_dir() + '.mbox',
                                  mlist.internal_name() + '.mbox'))
            ctype = 'text/plain'
        elif true_filename.endswith('.gz'):
            import gzip
            f = gzip.open(true_filename, 'r')
            f = open(true_filename, 'r')
    except IOError:
        msg = _('Private archive file not found')
        doc.AddItem(Header(2, msg))
        print doc.Format()
        syslog('error', 'Private archive file not found: %s', true_filename)
        print 'Content-type: %s\n' % ctype

Anyone seen this problem?  Is my Mailman or Python install broken?

Any advise or help really appreciated.

Thanks a lot,

Matthew Kalastro
Webmaster, Baskin School of Engineering, UC Santa Cruz
http://www.soe.ucsc.edu/ http://ssh.soe.ucsc.edu/ https://webmail.soe.ucsc.edu/
Baskin Engineering, rm 138, UCSC, 1156 High St., SC, CA 95064  831.459.5354

More information about the Mailman-Users mailing list