[Mailman-Users] Postfix and some mailman problems

Christian Schoepplein mail at schoeppi.net
Thu Jul 24 17:20:32 CEST 2003


I have some problems with postfix and mailman and I don't know how to 
solve them :-(.

I'm using a machine that responds on tow domains (dom1.de and dom2.de).  
Postfix accepts mails for both domains without problems, messages to  
schoeppi at dom1.de and schoeppi at dom2.de are delivered correctly to the user 

On the box the newest mailman is running. For lists under dom1.de every 
thing is working fine. If I setup a list via the webinterface under  
dom2.de the list is created, but I can't send mails to the listaddress or 
the other aliases for the same list. Either I get no reaktion 
from mailman or the mailserver (errormessage etc.) or postfix produces the 
following error:

listenname at dom2.de
SMTP error from remote mailer after RCPT TO:<listenname at dom2.de>:
host mx.kundenserver.de []: 550 Unknown local part listenname
in <listenname at dom2.de>

What might be the reason for this behavior?

The list appears in mailman's alias-fileand the alias-database is build. 
Also postfix can read this files..., for dom1.de everything is working 

For default mailman uses dom1.de as hostnamepart for a list, when setting 
up a new list in the interface under dom1.de or dom2.de. but is it 
possible to use the hostnamepart dom1.de when accessing the webinterface 




and dom2.de when accessing the interface via 




Its also not so nice, that not all lists for dom2 are showen, when I 
access the admininterface via




If I try the same for dom1, everything is OK..., all list for dom1.de are 
shown for both URLs.

Maybe someone could give me some hints how to solve the problems above!!!

Best regards an thanks,

Christian Schoepplein | Beste Rockband der Welt: http://www.lily-rockt.de
mail at schoeppi.net     | Linux fuer Blinde: http://www.blinux.suse.de

More information about the Mailman-Users mailing list