[Mailman-Users] database error message when upgraded to 2.1.2

Richard Barrett r.barrett at openinfo.demon.co.uk
Fri May 2 20:53:33 CEST 2003

At 18:16 02/05/2003, NOW Website Coordinator wrote:
>At 07:23 AM 05/02/2003 +0100, Richard Barrett wrote:
>>>We use Mhonarc, and the job that is taking up all the CPU is the 
>>>outgoing runner:
>>So, presumably you have configure Mailman to deliver archivable message 
>>by command directly to MHonarc rather than having MHonarc get the 
>>material via list subscriptions.
>>It is a pity you did not mention the use of MHonarc to start with. The 
>>error message you quotedin your earlier post as being generated on 
>>mailmanctl start is eerily similar to one described in a file I found in 
>>MHonarc's distribution MHonArc2.5.13/doc/app-diagnos.html#warnings; I do 
>>not use MHonarc myself but grepping through an expanded distribution found it.
>>Warning: Database (dbversion) != program (prgversion) version
>>Indicates that the version of MHonArc updating an archive is different 
>>from the version of MHonArc that created the database file. Problems can 
>>arise if the database file changes in format from different version of 
>>MHonArc. See the release notes of the MHonArc distribution if changes in 
>>the databse format will effect older archives.
>>It seems a reasonable speculation that you have updated MHonarc at some 
>>point and this is the cause of the problem and possibly this problem has 
>>nothing to do with Mailman but that MHonarc is grinding exceeding small? 
>>It also explains why the problem appeared to followe Mailman. But maybe 
>>it is following MHonarc which is attached to Mailman??
>It is in fact likely that the database message is coming from MHonarc 
>which was upgraded -- thanks for the suggestion.

I would call it a racing certainty.

>However, I hadn't upgraded Mhonarc on the old server.  I also now just 
>removed the lines in mm_cfg on my Solaris server for an external archiver 
>(mhonarc), restarted mailman ... and it again went up to using around 75% 
>of the CPU, when it's really just sitting there.  So it's not Mhonarc 
>which is causing mailman to use up all available CPU.

But the corollary of a message being output by MHonarc when mailmanctl was 
started is: was this caused by Mailman handing off a message for archiving 
to MHonarc for archiving and did this provoke MHonarc's  warning message? 
If so, where did the message come from if (as I think your are saying 
below) the incoming MTA is not running and delivering messages to Mailman? 
Also, is there any sign of messages being inserted into the MHonarc 
archives which appear to be associated with the MM-MHonarc interaction at 
mailmanctl start time? What happens if you re-enable the archiving scheme 
and restart mailmanctl? Does the warning message come back too?

>I decided to use the Qrunner command and try and run one runner at a 
>time.  Here's what I did, I just commented out one runner each and ran it:
>     ('ArchRunner',     1), # messages for the archiver
>#    ('BounceRunner',   1), # for processing the qfile/bounces directory
>#    ('CommandRunner',  1), # commands and bounces from the outside world
>#    ('IncomingRunner', 1), # posts from the outside world
>#    ('NewsRunner',     1), # outgoing messages to the nntpd
>#    ('OutgoingRunner', 1), # outgoing messages to the smtpd
>#    ('VirginRunner',   1), # internally crafted (virgin birth) messages
>     ]
>and the winner was .... the OutgoingRunner.  The rest were very behaved, 
>but the Outgoing Runner took up over 70% of the CPU on a machine that is 
>sending *nothing* out.  Postfix is shut down.

That seems to demonstrate that the OutgoingRunner thinks it has work to do 
and load in not being generated by an Archiver.

I assume Mailman is using SMTP to pass outgoing mail to your outgoing MTA? 
Are the outgoing and incoming MTAs one and the same?

Are you saying that the outgoing MTA used by Mailman is not running and 
accepting mail on port 25? If so, this might offer an explanation if MM has 
outgoing mail to send.. Mailman can be fairly aggressive in trying to hand 
off mail to an SMTP server if it has outgoing mail to send. Mailman could 
just be looping hard trying to get a connection to the MTA in order to send 
mail out.

As there any evidence of mail in the $prefix/qfiles/* directories? Is there 
no evidence of what is happening in any of MM's logs; the qrunner, error 
and smtp-failure logs for instance?

>Tried it on the new Linux machine, and same result.  Outgoing runner by 
>itself takes up 97% of my machine's CPU.  Note I am doing a full 
>mailmanctl stop and start to test this.
>Thanks for everyone's help.  Any suggestions as to how to get the outgoing 
>runner to behave?

More information about the Mailman-Users mailing list