[Mailman-Users] Mailman messages using postfix default hostname instead of virtuals hostname

Rick Erlandson ricky at elhost.com
Wed May 14 00:56:05 CEST 2003

I have setup Mailman on Mandrake 8.2, on a system that has been running
postfix 1.1.11 with virtuals (in mysql).  I have couple of issues that may
be related.. not sure.  First, when I run newlist it creates the aliases
file ok, but it never creates the virtual-mailman file.  Everything I've
read indicates it should.

So, I touched the file, ran check_perms -f which adjusted its file
permissions.  Then I ran newlist again to create another new list. still it
adds nothing to that file.  When I run genaliases it does its thing and
creates virtual-mailman.db, but it empties the original files contents (I
put somelines in myself).  Maybe it is supposed to do that, but it doens't
work and postfix complains about a non-existant user.

To see if it would remove the non-existant user error I added the lines to
virtual-mailman that I thought should be there (from some examples I came
across) and ran postmap myself.  It created the .db version of the file and
postfix stopped complaining about the non-existant user.

This would be great and happy except now when the list service replies back,
it is always using system hostname instead of the virtual hostname (wpc.ca)
that I want the list service to be on.  In both the email address and the
website for confirmation.

<the bottom of my mm_cfg.py is:>

MTA = 'Postfix'
DEFAULT_URL_HOST = 'www.wpc.ca'



<virtual-mailman looks like this (when I created it manually)>

burrtheatre at wpc.ca		burrtheatre
burrtheatre-join at wpc.ca 	burrtheatre-join

</so on and so forth...>

Any ideas would be appreciated.  I am especially puzzled as to why mailman
never creates the virtual-mailman file... I can't see any error message
about it either...

Rick Erlandson

More information about the Mailman-Users mailing list